Skip to content

superlu_dist: compile fix for v5.4.0

Created by: balay

This issue is with xsdk build of trilinos with latest superlu_dist [version 5.4.0

This patch fixes this issue for me.

Either a merge - or a more appropriate patch - that gets the trilinos build working with superlu_dist v5.4.0 would be great!

This incompatibility also prevents petsc from using trilinos with superlu_dist-v5.4.0

cc: @keitat as xsdk liaison to trilinos - please follow-up on this issue - and fill up all the necessary trilinos requirements so that PR gets accepted or this incompatibility is resolved via a different patch

cc: @jwillenbring, @curfman

Merge request reports